Основы конфигурирования в системе '1С Предприятие 8.0'


    73c64bed     

Встроенный язык. Операторы


Операторы имеют вид стандартного обращения к процедуре, за исключением оператора присваивания (А = В;) и синтаксических конструкций встроенного языка (например, таких как Для, Пока, Если). Между собой операторы обязательно следует разделять символом ";" (точка с запятой). Конец строки не является признаком конца оператора, т.е. операторы могут свободно переходить через строки и продолжаться на другой строке. Можно располагать произвольное число операторов в одной строке, разделяя их символом ";".


Операторы языка в программном модуле можно подразделить на две категории: операторы объявления переменных и исполняемые операторы.

Операторы объявления переменных создают имена переменных, которыми манипулируют исполняемые операторы.

Любой исполняемый оператор может иметь метку, используемую в качестве точки перехода в операторе "Перейти".

В общем случае формат оператора языка следующий:

~метка: Оператор[(Параметры)][ДобКлючевоеСлово];

Одним из операторов являются циклы. Во встроенном языке различают следующие виды циклов:

  • Пока <условие> цикл.
  • Для каждого <имя переменной> из <имя коллекции> цикл.
  • Для <имя переменной> = <начальное значение> по <конечное значение> цикл.

Для досрочного прекращения цикла используется оператор "Прервать".

Пример использования цикла "для каждого":

// Создание массива Массив = Новый Массив(10);

// Заполнение массива Для Сч=0 по 9 Цикл Массив[Сч]=Сч; КонецЦикла;

// Индикация массива Для Каждого Элемент из Массив Цикл Сообщить(Элемент); КонецЦикла;

Рассмотрим следующий вид операторов - "условия". Условия оформляются следующим образом:

Если <ключевое слово > (&lлогическое выражение>) <ключевое слово> (<логическое выражение>) : : ИначеЕсли <ключевое слово> (<логическое выражение>) <ключевое слово> (<логическое выражение>) : : Иначе КонецЕсли;

В записи условий могут использоваться следующие ключевые слова: "И", "ИЛИ", "НЕ". Ветвей "ИначеЕсли" может быть неограниченное количество или ни одной.

Логические выражения имеют тип Булево. При этом, если в условии используется несколько логических выражений, соединенных ключевыми словами "И" или "ИЛИ", и по значению первого логического выражения можно определить значение всего условия, то вычисление значений остальных логических выражений не производится. Например:

Значение1 = 5; Значение2 = 4; Если (Значение1 = 5) или (Значение2 = 4) тогда

В данном случае в условии используется ключевое слово "ИЛИ". Поэтому, если значение первого логического выражения Истина, то вычисление второго логического выражения произведено не будет.

Пример укороченной записи логического выражения:

Значение1 = Истина; Значение2 = Ложь; Если Значение1 И НЕ Значение2 тогда



Содержание  Назад  Вперед