Основы конфигурирования в системе '1С Предприятие 8.0'


    73c64bed     

Встроенный язык. Инструкции препроцессора


Код системы 1С:Предприятие 8.0 может исполняться в файловом, клиентском и серверном окружении, а также в сессии COM-соединения. При этом можно в конфигураторе настроить место выполнения (на сервере или на клиенте) различных процедур и функций для каждого из вариантов.

Для указания разрешения использования процедур следует воспользоваться директивой препроцессора.

Конструкция типа

#Если Сервер тогда : Процедура Проц1() экспорт : КонецПроцедуры : #КонецЕсли

позволит указать системе, что процедура Проц1() должна выполняться на сервере, а конструкция

#Если Клиент тогда : Процедура Проц2() экспорт : КонецПроцедуры : #КонецЕсли

укажет на выполнение Проц2() на клиентской машине.

Для включения использования процедур и функций в сессии внешнего соединения применяется инструкция препроцессора

#Если ВнешнееСоединение тогда : #КонецЕсли




Содержание  Назад  Вперед