Введение в конфигурирование 1Cv8 - Основные объекты


    73c64bed     

будет помещение  в  диалог  формы 


/p> 26











ОбластьТабЧасти. Параметры. Код=Выборка. Код;

 ОбластьТабЧасти. Параметры. Наименование=Выборка. Наименование;

 ОбластьТабЧасти. Параметры. РозничнаяЦена=Выборка. ЦенаПродажи;

 ОбластьТабЧасти. Параметры. РасшифровкаЭлем=Выборка. Ссылка;

 КонецЕсли;

 ТабДок. Вывести (ОбластьТабЧасти);

 КонецЦикла;

 ТабДок. Защита = Истина;

 ТабДок. ТолькоПросмотр = Истина;

 ТабДок. Показать ();

 КонецПроцедуры



Последним  шагом  будет помещение  в  диалог  формы  кнопки  и указание в свойстве «Нажатие» имени процедуры «Печать».

Подобные печатные формы объектов можно создавать с помощью конструктора печатных форм. Вызвать его можно либо сделав щелчок правой клавишей мыши на заголовке объекта в дереве метаданных, либо воспользовавшись кнопкой «Конструкторы», расположенной в основной форме настроек объекта на закладке «Макеты».


Содержание  Назад  Вперед